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Batch Converter Introduction
The Batch Converter Plug-in for Sound Forge will save you the countless hours of otherwise tedious time 
needed to convert or modify tens, hundreds and even thousands of sound files. Simply add the files that 
need to be processed to the batch list, select the processing required and the destination folder and then 
select Convert! The Batch Converter will do all of the work for you while you use other applications or 
better yet – go to a movie.

The Batch Converter allows you to apply any of the effects, processes, and tools installed in Sound 
Forge. Applying features like frequency filtering, dynamic compression, noise gating, and normalization 
squeeze every bit of dynamic and frequency content from your sound files into the final format you 
require. Conversion settings may be saved and used repeatedly to maximize the aural quality of the 
destination sound files. These settings make routine conversions only a couple of mouse clicks away.

Before running a batch, you can quickly build up to five previews (with comments) to monitor the effects of
different settings. After running a batch, a single click will open either the source or destination files in 
Sound Forge for closer analysis.
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Basic Steps
The Batch Converter has many different applications, but the basic setup steps are always the same. The
general procedure used to process sound files with the Batch Converter tool is outlined below. More 
detailed information is presented in Conversion Settings and related sections.

1. Open the Batch Converter Window.
The Batch Converter window is opened by selecting Batch Converter from the Tools menu in 
Sound Forge. It contains a file list (initially empty) showing sound files to convert and their status. 
The window also displays the output path (at the top) and brief information about the currently 
selected output file format and processing parameters (in the bottom status bar).

2. Add the sound files you want to convert.
Select Add from the File menu of the Batch Converter window. In the File Add dialog, you can 
select one or more sound files you wish to convert and add them to the batch list. Once you’ve 
selected the files, press the Add button. You can also add files by dragging sound file icons from 
outside of Sound Forge (from File Manager or any Windows 95 Explorer window) into the Batch 
Converter window. In Windows 95, you can select all of the files in a folder by pressing Control+A 
in the File Add dialog.

3. Select the destination file format.
Select Conversion Settings from the Options menu. The Conversion Settings dialog is used to 
determine both the destination file format and audio processing that will be performed on the 
selected files. If you want the files to be converted to a specific file format, the File Format 
checkbox must be turned on.

4. Add audio processing functions.
Select the audio processing functions you wish to apply to your batch of files. This is done by 
selecting functions, setting their parameters (or using presets) by pressing the Settings button, 
and pressing the Add button . To edit a function’s parameter once its been added to the script 
list, double click on it. Once you’re done adding functions, press OK.

5. Select a destination directory for the converted files.
Select the Destination Folder item in the Options menu to set the location that the converted files 
will be saved. If you enter a folder that does not exist, the Batch Converter will create it for you.

6. Convert!
Select the Convert! menu item to begin the conversion. A progress meter will be displayed that 
shows the status of each function performed on each sound file until the batch processing is 
complete. You can cancel a batch at any time by clicking the Cancel button. 



Saving conversion settings
All of the settings in the Conversion Settings dialog can be saved for convenient reuse by selecting the 
Save As button in the Conversion Settings dialog. The Batch Converter comes with several presets you 
can use as good starting points.



Processing specific sound files in the list
To process a single sound file from the file list, first select the file by clicking on the file in the list. Then, 
select Convert Selected from the File menu (or from the Shortcut menu activated by clicking the right 
mouse button in the Batch Converter window). You can select multiple files by holding down the mouse 
button while dragging the mouse over the files. Also, the Edit menu contains several options for managing
the sound files to be processed. To re-process an already processed file, you must first reset it by using 
Reset Selected in the Edit menu.



Previewing a conversion
Before performing all of the conversions, you can preview the results on smaller audio sections in the 
Preview Conversion window. To open the Preview Conversion window, click the Preview button from the 
Conversion Settings dialog.

The Preview Conversion window allows you to build up to five different preview clips. To build a preview 
clip, select a file from the Active File list in the Preview Conversion window (one or more sound files must 
have previously been added to the batch list using the Add command in the File menu). 

Once you’ve selected a sound file to preview, pressing B (Build) will create and play a preview clip of the 
selected file using the current parameters in the Conversion Settings dialog. You can re-play the preview 
clip by pressing the > (Play) button, while S (which appears on the play button) stops playback. To play 
the unmodified clip from the active file, press the larger Play button on the right side of the window.

The section of a sound file used for creating the preview clip is determined by the Preview Start and 
Length controls. Also, comments can be typed in the edit fields to the right of the B (Build) and > (Play) 
buttons.

Since the Conversion Settings dialog and the Preview Conversion window can be open and accessed 
simultaneously, you can conveniently change parameters and preview the results.

The effects of saving to a compressed audio format will not be heard when using
the Preview dialog. You must open the processed file to do so.



Helpful Hints
Here’s some ideas on how to make the most out of the Batch Converter plug-in:

1. In Windows 95, you can add all of the files in a folder from the File Add dialog by pressing 
Control+A. Holding down the Shift key while clicking on files will select all of the files in between. 
If you hold down the Control key, files will be selected one by one.

2. You can drag files from File Manager into the Batch Converter window to add them. In Windows 
95, you can drag and drop sound files from any Explorer window.

3. Right clicking on the Batch Converter file list brings up the Shortcut Menu. From this menu, you 
can select from the most common operations.

4. Once you’ve processed the sound files, you can quickly open the source and destination files by 
selecting the sound file in the Batch Converter window and choosing Open Source or Open 
Destination from the Shortcut Menu.

5. When converting files from 16 to 8 bits, it is essential that you utilize the entire dynamic range to 
minimize the audibility of the quantization noise. This is accomplished by compressing and 
normalizing the files. Also, dithering makes the unavoidable quantization noise a bit more 
palatable.

6. If you are running very low on hard-drive space, you can select Delete Source after Conversion 
from the Options menu to free up some room.



Conversion Settings
The Conversion Settings dialog is opened by selecting the Conversion Settings option from the Options 
menu. This dialog is used to specify the destination file format and audio processing functions that will be 
applied to the selected files.

To select a function, choose the appropriate Sound Forge Class and Function you wish to apply. For each
function, presets available in Sound Forge may also be selected. To view and/or change the parameters 
used, press the Settings button. To change the parameters of a function that has already been added to 
the script, double-click on the function’s name. 

File Format
Determines the output file type. If this option is turned off, then the source file format is preserved for 
the destination sound file. When the File Format is of Raw, RealAudio, or Video for Windows, the More 
button provides control over the destination binary format.
Data Format
Many File Formats allow you to select between a variety of different Data Formats. For example, when 
the Audio Compression Manager (ACM) is installed, the Microsoft Wave file format allows for a variety 
of compressed data formats as well as standard PCM data.
Add or remove Summary and Extra Information
When checked, the modifications selected in the Summary and Extra Information dialog are applied to 
the destination sound file. If this option is turned off, all Summary and Extra information in the source 
sound files is preserved, if possible, in the destination files. Some file formats do not let you store 
additional information in the file. In such cases this field is ignored.
Use Plug-Ins
Allows you to utilize processing features supplied by any plug-ins you may have installed. This is also 
used to guarantee that no processing functions will be applied while batch converting to a common file 
format.
Class
Allows you to choose the menu (from a drop-down list) where the function you wish to apply is located 
in the Sound Forge main menu.
Function
Allows you to select the particular function you wish to apply to the files.
Preset
Allows you to choose any preset for the function that you specified that had been created and delivered 
with Sound Forge or choose a preset that you have created.
If (Untitled) is selected, the last used parameters will be used. To ensure using a certain set of 
parameters, save the current parameters by using the Save As button in the functions dialog.
Settings
Brings up the corresponding function’s dialog. This allows you to view the presets and change the last 
used parameters. To change the settings of a function already in the Batch Script, double click on it.
Batch Script
Contains the functions that will be applied to each file and their exact order, going from top to bottom. 

After you choose the function you wish to apply, selecting add  will append it to the list whereas 
remove 

 will delete it. The up/down buttons 

 change the order in which the functions will take effect.
Double clicking on a function in the list will bring up the settings dialog for the selected function.

To save all of the current settings except the Summary Information fields and RealAudio metafile path, 
select Save As. The Summary Information fields for Microsoft Wave .WAV and Video for Windows .AVI 



files and the RealAudio metafile path are stored globally to all presets. Refer to the documentation for 
Summary and Extra Information for more details.

Previewing all processing options can be performed by selecting the Preview button. It should be noted 
that data compression options selected in the Data Format list will not be represented in the previewing 
process. Refer to the Preview Conversion window documentation for further details.



Other Settings
Preview Conversion 
Raw File Open Settings 
Real Audio Save Settings 
Destination Directory 
File Add 
Error List 



Destination Raw Attributes
The Destination Raw Attributes dialog is selected by pressing the More button to the right of the File 
Format list in the Conversion Settings dialog. This option is only available if the File Format selection is for
Raw files. Use this dialog to set the destination attributes when converting to Raw file formats.

Name
This list of file formats contains preset versions of raw file storage formats commonly used by other 
applications. You can create a new file format by using the Save As button to save the current storage 
parameters.
Sample Type (8 Bit PCM, 16 Bit PCM, G.711 u-Law, G.711 A-Law)
Format used to store each sample.
Format (Unsigned, Signed, Sign bit)
Binary format of each sample (for PCM sample types only).
Channels (Mono/Stereo)
Number of channels, or tracks, stored in the file.
Byte Order (Little or Big Endian)
Order in which the high and low bytes of a 16 bit sample are stored. Little Endian (low, high) is used by 
Intel microprocessors, while Big Endian (high, low) is used by Motorola microprocessors.



Summary and Extra Information
The Summary and Extra Information dialog is opened by pressing the More button next to the Add or 
remove Summary and Extra Information in the Conversion Settings dialog. This dialog is used to 
modify information in sound files when they are being converted. All options, except Remove Sampler 
Information, apply to Microsoft Wave files only.

It is sometimes desirable to remove all extraneous information from sound files to save disk space or to 
ensure compatibility with software that mishandles the extra data.

Remove Summary Information
When checked, all Summary Information fields will be removed from Microsoft Wave files.
Remove Sampler Information
When checked, all Sampler Information will be removed from sound files that support this information 
(see comments below).
Remove Region and Play Lists
When checked, all Markers, Regions and Playlist information will be removed from Microsoft Wave files.
Remove Unknown Information
When checked, unknown information chunks found in Microsoft Wave files will be removed.
Summary Information fields to add or replace
To add or replace a field, such as copyright information, make sure that it is checked (click in the box to 
the left of the field name) and enter the desired text into the Contents of selected field edit box. Any 
field that is checked but left blank (no text) will be removed. Unchecked fields are left unmodified. 
Summary Information is only relevant to Microsoft Wave files.

Several file formats supported by the Batch Converter allow Loop points and other Sampler related 
information to be stored within the files. Formats that support sample information include Microsoft Wave, 
Macintosh AIFF, Turtle Beach SampleVision, Digidesign/Atari Sound Designer 1, Gravis Patch and 
Sample Dump Standard (SDS) files. By default, the Batch Converter will retain this information when 
converting between these file formats. If you wish to remove this information during the conversion, then 
turn on the Remove Sampler Information option.

Saving presets in the Conversion Settings dialog will store all settings except Summary Information fields.
This is done because Summary Information is usually common between different batches. If different 
Summary Information is required between batches, you will need to reenter the information for each 
batch.



RealAudio Settings
This dialog is reached when you select Real Audio (.ra) from the File format list in the Conversion 
Settings dialog and press the More button. This feature is only available for Windows 95 and NT running 
in x86 processors.

Desired Compression Type (RealAudio 14.4/RealAudio 28.8/Bandwidth Negotiation)
Determines the data rate required to play back the file. Bandwidth Negotiation generates both 14.4 and 
28.8 files and saves them both in a RealAudio Bandwidth Negotiation-compatible folder
Automatically Generate RealAudio Metafiles (RAM)
Simplifies authoring files for the Internet by automatically creating RAM files that are compatible with 
the RealAudio Player.
RealAudio Server Path
Defines the server path used as the base in RAM entries.
Use Alternate Destination Folder for RAM files
Allows you to store your RAM entries apart from where the RealAudio files are accessed. The Browse 
button is a convenient way to select an existing folder.
Play Start Position (0 to 600 seconds)
Specifies the start of a segment that will be played from the RealAudio file. This information is stored in 
the RAM file. If the value is 0 (default) the entire file will be played.
Play Length (0 to 32,000 seconds)
Specifies the length of a segment that will be played from the RealAudio file. This information is stored 
in the RAM file. If the value is 0 (default) the entire file will be played.



Processing Order
The order in which processing operations occur in the Batch Converter is determined by the order in 
which functions appear in the Batch Run List. Here are some more tips on using the processing order to 
your advantage.

1. Perform Stereo to Mono conversion first. This will save processing time, since all following 
operations will need to process half of the data.

2. Resample to a lower rate early on. Again, this will cut down on processing time.
3. Remove any DC Offsets early on. This will ensure that the following operations can measure 

levels and zero crossings more accurately.
4. Remove frequencies below 20 Hz with the Paragraphic EQ early on. (This operation will also 

remove DC offset)
5. Normalize the sound file after all the processing is done.
6. Convert from 16-bit to 8-bit at the very end.



Preview Conversion
The Preview Conversion window, which is opened by selecting Preview from the Conversion Settings 
dialog, provides a quick method of testing different processing options on small regions of sound. You can
keep the Preview Conversion window open while you change parameters in the Conversion Settings 
dialog making it easy to try out different settings.

Note: The previews that are created do not include data compression options. Therefore, if you choose a 
compressed format for the destination (i.e. Microsoft ADPCM or Dialogic VOX ADPCM), you will not hear 
the effects of the compression in the preview. The preview consists of only the processing performed 
before saving the destination file. If you need to preview the effects of data compression, simply select 
one or more files to convert, convert them, then use the Open Destination command in the File menu. 
Once the files are open in Sound Forge, you can listen to the true effects of the data compression.

If no data compression options are chosen, then the preview created is a true representation of the final 
output.

Active file
Selects the file that will be used to create a preview clip. You can listen to this file by pressing the Play 
button. Only the first 50 files from the batch list are available in the Active file list.
>
Press to play the preview clip after it has been created. During playback, you can press this button 
again (it will turn into an S) to stop playback.
B
Press to build and play a preview clip from the Active file using the current conversion settings.
Comment fields
The text fields to the right of the play (>) and build (B) buttons allow you to enter comments about the 
conversion results and/or the parameters used.
Preview Start and Length
Determines the region in the Active file that will be used to create a preview clip.
Play
Plays the unaltered portion of the Active file for comparing a preview with the original material.
Close
Closes the Preview Conversion dialog.
Clear All
Clears all Preview buffers and releases any disk space used to store the preview information.
Settings
Switches the active window (keyboard focus) back to the Conversion Settings dialog. This is easier to 
remember than the Alt+F6 standard defined by Windows, though both methods work.



Source Raw Attributes
The Source Raw Attributes dialog is displayed by selecting the Source Raw Attributes option from the 
Options menu. This dialog is used to specify the format for all raw source files in the list. Using Raw file 
types may be necessary to open sound files that are not stored in one of the standard file formats 
supported by the Batch Converter.

All Raw files in a single batch list must have the same attributes. If multiple raw formats need to be 
converted, they must be converted as separate batches.

Name
List of preset formats available. To create your own format from the selected parameters, press Save 
As.
Sample Rate (2,000-60,000 Hz)
Sample playback rate which will be used by Sound Forge when playing the file.
Sample Type
Format used to store each sample.

8 Bit PCM
Uncompressed linear format.
16 Bit PCM
Uncompressed linear format.
G.711 u-Law
Compressed format commonly used for telecommunications in the United States.
G.711 A-Law
Compressed format commonly used for telecommunications in Europe.

Format (Unsigned, signed, sign bit)
Binary format of each sample (for PCM sample types only).
Channels (Mono/Stereo)
Number of channels, or tracks, stored in the file.
Byte Order (Little or Big Endian)
Order in which the high and low bytes of a 16 bit sample are stored. Little Endian is used by Intel 
microprocessors, while Big Endian is used by Motorola microprocessors.
Header Bytes
Number of bytes stored in the file before the sound data.
Trailer Bytes
Number of bytes stored in the file after the sound data.



Destination Directory
This dialog sets the destination directory. 



Errors
The Errors dialog is displayed by choosing the List Errors option in the File menu. This dialog contains a 
list of errors for a file which occurred during a conversion. If one or more errors were encountered while 
converting a file, they are logged and can be displayed with this dialog. These errors can aid in 
determining what problem(s) occurred and how to fix them.



File Add
The File Add dialog allows one or more files to be added to the batch list. Select the files to add and click 
the Add button. The selected files will then be appended to the batch list as source files. Note that some 
file types (Dialogic VOX) must explicitly be selected in the Files of type list to properly add them to the 
batch list.

On Windows 95, using the 32 Bit version of the Batch Converter, you can select all files in the File Add 
dialog by placing the focus in the list of files and pressing Ctrl+A. This is a poorly documented feature of 
Windows 95 common file dialogs and is very useful when working with the Batch Converter.

Files can also be added to the batch list by dragging files from the File Manager and dropping them onto 
the Batch Converter window. If you are using the Windows 95 operating system, you can drag and drop 
files from any Explorer window. However, it may be necessary to add Dialogic VOX files using the File 
Add dialog. This is only necessary if the files do not end with a .VOX extension. The reason for this 
limitation is the lack of information in these files for the Batch Converter to automatically determine the 
type. You must tell the Batch Converter what types of files these are.



File Menu
Add
Opens the File Add dialog for selecting the files to process. Files can also be added to the batch list by 
dragging files from the File Manager and dropping them onto the Batch Converter window. If you are 
using the Windows 95 operating system, you can drag and drop files from any folder.
Open Source
Opens the selected source (not converted) file in Sound Forge.
Open Destination
Opens the selected destination (converted) file in Sound Forge. The destination file can only be opened
if a successful conversion has completed and that Status of the file is Done.
Convert All
Begins conversion of all of the files in the list. If a file has already been converted and contains a Status
of Done, then it will not be converted. If you want to convert Done files again, you must reset them 
using the Reset Selected or Reset All options in the Edit Menu.
Convert Selected
Begins conversion of the selected files only. All files in the selection that do not have a Status of Done 
will be converted (including files that had errors from a previous attempt).
List Errors
Displays a list of errors that were encountered during a conversion for the selected file. If no errors 
occurred, then this option is grayed. Use this option to determine why the file was not converted.
Properties
Displays various properties for the selected file.
Add Batch Script
Imports a batch script that was packaged by using the Save Batch Script command. It will install the 
selected file into the Batch Converter along with any new plug-in presets that may be required by the 
new script.
Save Batch Script
Allows a selected script to be packaged for transferring to different computers. The function creates a 
selected file with all the information necessary to install the selected script for use on another computer 
including user created presets for any plug-in. The file can then be passed to another user and installed
using Add Batch Script.
Close
Closes the Batch Converter window.



Add Batch Script
Use this dialog to select a Sound Forge script file (.sfz) to import. The script, along with all of its function 
presets will be added to the Batch Converter and corresponding functions.



Save Batch Script
Use this dialog to save a batch script to a Sound Forge script file (.sfz). All of the function’s preset will be 
stored in the file. This is useful for sharing presets and scripts with other Sound Forge users.



Edit Menu
Invert Selection
Inverts the current selection. All files that are selected (highlighted) will be unselected; all files that are 
not selected will be selected.
Select Done
Selects all files that have a Status of Done. Files become Done after they have been successfully 
converted.
Select All
Selects all files in the list.
Remove Selected
Removes all files that are selected (highlighted) from the list.
Remove Done
Removes all files that have a Status of Done from the list. Files become Done after they have been 
successfully converted.
Remove All
Removes all files from the list.
Reset Selected
Resets the Status of all selected files. After resetting a file’s Status, another conversion can be run on 
the file.
Reset All
Resets the Status of all files in the list.



Options Menu
Conversion Settings
Opens the Conversion Settings dialog which allows you to select the destination file format and audio 
processing parameters used to convert files.
Source Raw Attributes
Opens the Source Raw Attributes dialog, which contains information on how to open raw data files. All 
raw data files in the list must have the same attributes. If you need to convert multiple raw data file 
types, then simply run a different batch for each file type.
Destination Directory
Displays a dialog for entering the Destination Directory that will receive the converted files.
Show Full Path
This option switches between showing the full path to every file in the list and just showing just the file 
name. This can be useful if you are converting files from multiple directories.
Stop on Errors
When this option is turned on, a dialog appears when an error occurs during processing. Otherwise, 
errors are logged and processing continues without stopping. This option should be turned off if you 
want the batch to run unattended. When Stop on Errors is turned off, all destination file name conflicts 
are resolved by renaming the destination file to a new and unique name. The Batch Converter will 
always choose the safest resolution possible when running unattended.
Delete Source After Conversion
When this option is turned on, source files are deleted immediately after a successful conversion. This 
option is used to save disk space during processing. This is option is very safe if you are certain that 
you will be satisfied with the converted files. The source file is only deleted after the destination file has 
been successfully saved. If any errors are encountered during the conversion, the source file will not be
deleted.
Rename with Long File Names
If a destination file name conflicts with an existing file, then the destination file will be renamed to a new 
and unique name. When this option is turned on, the new name chosen for the destination file will use 
the same name with a unique number appended to the end. The new file name can exceed the 8 
character limit of non-32 Bit operating systems.
When this option is turned off, then new file names will truncate the original file name to 6 characters 
and append a unique two character number. This maintains compatibility with the 8.3 naming 
convention.
This option is only available in the 32 Bit version. The 16 Bit version will always use the 8.3 naming 
convention.



Convert! Menu
The Convert! menu starts the batch conversion process for all files in the list. This menu is the same as 
selecting the Convert All option from the File menu. If you want to convert only the files that are selected 
in the list, then you should use the Convert Selected option in the File menu. Files that are marked Done 
will not be processed again (you must first reset a file if you want to process it again).



Help Menu
Contents
Displays the table of contents in the Batch Converter Plug-In Help file.
About Batch Converter
Opens the Batch Converter’s About dialog which displays version and copyright information.



Shortcut Menu
The Shortcut Menu for the Batch Converter is reached by clicking the Right Mouse Button in the Batch 
Converter window. The Shortcut menu provides a quick method of reaching the most common commands
for the Batch Converter. The keyboard command for the Shortcut menu is Ctrl+Shift+F10.

Add
Opens the File Add dialog for selecting the files to process. Files can also be added to the batch list by 
dragging files from the File Manager and dropping them onto the Batch Converter window. If you are 
using the Windows 95 operating system, you can drag and drop files from any folder.
Remove
Removes all files that are selected (highlighted) from the list.
Reset
Resets the Status of all selected files. After resetting a file’s Status, another conversion can be run on 
the file.
Open Source
Opens the selected source (not converted) file in Sound Forge.
Open Destination
Opens the selected destination (converted) file in Sound Forge. The destination file can only be opened
if a successful conversion has completed and that Status of the file is Done.
Convert All
Begins conversion of all of the files in the list. If a file has already been converted and contains a Status
of Done, then it will not be converted. If you want to convert Done files again, you must reset them 
using the Reset Selected or Reset All options in the Edit Menu.
Convert Selected
Begins conversion of the selected files only. All files in the selection that do not have a Status of Done 
will be converted (including files that had errors from a previous attempt).
List Errors
Displays a list of errors that were encountered during a conversion for the selected file. If no errors 
occurred, then this option is grayed. Use this option to determine why the file was not converted.
Properties
Displays various properties for the selected file.
Select All
Selects all files in the list.



Run Batch Script Introduction
The Run Batch Script tool allows you to apply batch processing to open sound files in Sound Forge. 
Scripts that are created with the Batch Converter are selected and applied to the current selection, just 
like other functions in Sound Forge. In this way, it’s like using new functions that are composed of a any 
combination of any of Sound Forge’s effects, tools, and processes.



Run Batch Script Tutorial
The following steps outline the general procedure for using the Run Batch Script tool. More detailed 
information on using this tool is given in Run Batch Script in the Reference section.

1. Open a Sound File
If you have a selection, only the selected sound data will be processed. Unlike the Batch 
Converter, the Run Batch Script function works on files open in Sound Forge, just like most other 
functions.

2. Open the Run Batch Script Dialog
The Run Batch Script dialog is opened by selecting Run Batch Script from the Sound Forge Tools
menu. 

3. Select the Batch Script Name 
The presets in the list are created in the Batch Converter’s Conversion Settings dialog. For more 
information on creating new scripts, see Conversion Settings in the Batch Converter Reference 
section. When you select a script, all of the script’s functions will be displayed below.

4. Press OK
The function listed will be applied to the current selection, in their respective order.



Run Batch Script
The Run Batch Script tool allows you to apply batch processing to opened sound files in Sound Forge. 
Scripts that are created with the Batch Converter are selected and applied to the current selection. To edit
an individual function’s parameters, you must use the Batch Converter’s Conversion Settings dialog.

Name
This list contains all of the scripts created using the Batch Converter, along with the default scripts 
included with the Batch Converter Plug-In.
Batch Script
Displays the list of functions that will be applied, in their perspective order.
Save Result to a New Sound File Using the Specified Format
Saves the converted data in the format you have chosen in a new sound file.



Batch Script Save As
This dialog is reached when you press OK from the Run Batch Script dialog if you have selected to 
Save result to a new sound file using the specified file format.
You can enter the name of the file you wish to create and the directory where it will be created.



Extract Regions Introduction
The Extract Regions tool will automatically extract any number of Regions from a sound file to separate 
sound files. Using this tool allows you to work on related sounds in a single sound file and then 
automatically extract the individual events to separate sound files. Combining the Auto Trim/Crop, Auto 
Region and Record functions in Sound Forge with the Extract Regions tool can eliminate hours of 
monotonous work when creating sound sets or saving multiple takes.

For example, in the Record dialog, if you select Multiple Takes with Regions, you create a new region 
each time you press Record and Stop. Afterwards, you can rename the regions and run the Extract 
Regions tool to create individual files, at which point you can run the Batch Converter to convert and 
process the files.



Save As
Enter the name the batch script (.sfz) file you wish to save to and the directory where it will be saved.



Extract Regions Tutorial
The following steps outline the general procedure for using the Extract Regions tool. More detailed 
information on using the Extract Regions tool is given in the Extract Regions Dialog section.

1. Open or create a sound file containing one or more Regions.
The Extract Regions tool will extract and save one or more regions from the Regions List to 
separate sound files. As with most Sound Forge functions, the Extract Regions tool operates on 
the active window. Therefore, open or create a sound file that contains one or more regions.

2. Open the Extract Regions dialog.
The Extract Regions dialog is opened by selecting Extract Regions from Sound Forge’s Tools 
menu. This dialog will list all Regions in the active sound file and contains various controls which 
affect how and where regions will be extracted.

3. Select the Regions to be extracted from the Regions list.
When the Extract Regions dialog is first opened, all regions are selected for extraction. If you do 
not want to extract all regions, you can modify the list by clicking on the regions desired for 
extraction. Holding down the Ctrl or Shift keys while clicking allows multiple regions to be 
selected.

4. Choose a file name prefix.
The file name prefix is by default based on the active window’s title. This prefix will be used for all 
sound files created when extracting the selected regions. If you are using Long File Names (32 
Bit version only), then the destination file name will be the prefix combined with the Region name.

5. Select the Destination Directory.
All sound files created by extracting the selected regions will be written to the directory specified 
in the Destination Directory edit box. If you type a directory that does not exist, you will be asked 
if you want to create the directory. The Browse button provides a convenient method of selecting 
an existing destination directory.

6. Press Extract.
When you are satisfied with the parameters for extracting regions from the active sound file, click 
the Extract button. The regions will be extracted to Microsoft Wave sound files.



Extract Regions Dialog
The Extract Regions tool is used to create individual files from regions in the Regions List of a sound file. 
This feature makes it easier for you to record long files, create regions in the Regions List, and then save 
those regions as individual sound files.

The Extract Regions dialog is opened by selecting Extract Regions from the Sound Forge Tools menu. To 
use this function, simply select the regions that you wish to extract, select the destination directory, a 
prefix for the files, and press Extract. A Microsoft Wave file will then be created for each selected region in
the destination directory.

Regions to extract
This list contains all of the regions present in the active sound file. To select the regions you wish to 
create individual files from, click on them. You can hold the Control key down when clicking to select 
multiple regions. If you hold the Shift key down while clicking, all of the regions between the last and 
current selection will be selected. The Select All button provides a convenient way to select all regions 
in the list.
Destination directory
Determines the location where the extracted regions will be saved. If you enter a directory that does not
exist, then the Extract Regions tool will create it. Selecting the Browse button provides a convenient 
way to select an existing destination directory.
Browse
Displays a dialog allowing you to browse the available disk drives and directories for selecting an 
existing Destination Directory.
File name prefix
The files created will all begin with the text entered in this field. If the Use Long File Names for 
destination file names option not checked, then this prefix is truncated to the first 5 characters.
Use Long File Names for destination file names
When this option is turned on, the file names created can be up to 128 characters in length and may 
contain spaces. The files names will be the concatenation of the File name prefix and the region name. 
For example, if your prefix is set to This is my file_ and there is a region named Region 004 then the 
name used for extracting will be This is my file_Region 004.WAV.
When this option is turned off, the file names will conform to the 8.3 naming convention. These names 
consist of the first 5 characters from the File name prefix and a unique three digit number. For example,
if you have 4 regions selected for extraction, and your prefix is set to PREFIX, then the names used will
be PREFI000.WAV, PREFI001.WAV, PREFI002.WAV, PREFI003.WAV.
This option is only available in the 32 Bit version. The 16 Bit version will always use the 8.3 naming 
convention.
Extract
Selecting the Extract button will start the region extraction process. All regions that are selected in the 
Regions list will be extracted to separate files.
Play
Plays the region that has the focus in the list.
Select All
Selects all regions in the list.
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